Logo

Fehlersuche

Die Wikiweise-Software weist noch einige Bugs auf. Einige Phänomene sind jedoch "absichtlich" entstanden, d. h. sie sind keine Bugs sondern beruhen auf softwarespezifischen Eigenheiten.

Anzeigen

Bevor Du einen Bugreport machst, lies deshalb bitte diese Liste durch.

Komische Fehlermeldung im Artikel der Art *** Fehler im Wiki-Markup: Traf auf...

Allgemeines

Der Parser, der aus dem Quelltext eine Webseite macht, arbeitet etwas strenger als in der Wikipedia (dafür ist er auch flexibler und schneller zu erweitern). Wenn er mit irgendwas nicht klar kommt, lässt er den Absatz bei der Anzeige unter den Tisch fallen und blendet stattdessen eine Fehlermeldung ein.

Wenn das passiert, liegt es in der Regel daran, dass die Syntax im Quelltext nicht richtig ist. Meist hat das irgendwas mit den Verweisen zu tun:

  • nicht geschlossene Klammern, z. B. [[Dies ist ein Link ohne schliessende Klammer]
  • asymmetrische Überschriftenformatierung, z. B. ==Zwei Striche links und drei rechts===
  • aus der Wikipedia übernommene Fragmente mit Interwiki-Links
  • usw.

Wiki-Markup in den URLs von Weblinks

Wird ein einer URL eine Zeichenkombination benötigt, die normalerweise ein Wiki-Markup darstellt - z. B. zwei Unterstriche hintereinander, die ansonsten eine Tiefstellung einleuten würden - so muss die URL (hinter dem http://) durch nowiki-Tags eingeschlossen werden:

aus

http://<nowiki>www.rki.de/cln_006/nn_225164/DE/Content/Institut/Geschichte/Robert__Koch.html</nowiki>

sollte dann das werden: http://www.rki.de/cln_006/nn_225164/DE/Content/Institut/Geschichte/Robert__Koch.html

Die Suche funktioniert nicht richtig, zeigt bestimmte Artikel nicht etc.

Die ganze Suche ist noch nicht sehr ausgereift. Es wird eine fertige Softwarebibliothek verwendet (Lucene) und die muss noch ordentlich konfiguriert werden. Das ist aber ziemliches Feintuning, bislang fehlte hierfür noch die Zeit.

Die automatische Begriffsklärung funktioniert nicht

Problem: Artikel ((Klärungszusatz)) wurde angelegt aber der Link Artikel zeigt nicht dorthin und es wird auch keine automatische Begriffsklärung angelegt.

Lösung: Der Indexeintrag "HE" wurde auf den Artikelnamen mit Klammerzusatz gesetzt → "Index-HE:Artikel ((Klärungszusatz))". So kann die BKL-Routine den Artikel nicht erfassen → Entweder den Index-HE ganz weglassen oder auf "Index-HE:Artikel" stellen, dann klappt es.

Anzeigen